Connectivity issues in North America
Incident Report for Boostlingo
Postmortem

Boostlingo experienced application events on May 24th that led to service degradation. The service degradation was from 06:34 PDT to 7:16 PDT, in which users may have had limited to no access to the platform.

Our development team has concluded that an Azure cloud service restart caused our servers to lose connection, then service was degraded as all accounts reconnected simultaneously.

We are working together with this third party to identify the root cause, and based on those findings we will implement changes to prevent future impact from this type of event. Internally we have taken steps steps to rebalance the connection process by slimming down our dependence on third party servers. Additionally, we're applying a new algorithm to the reconnection flow to more evenly distribute the load on third party servers in the event that these servers go down.

Posted May 26, 2023 - 05:20 PDT

Resolved
This incident has been resolved.
Posted May 24, 2023 - 08:20 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 24, 2023 - 07:16 PDT
Investigating
We are investigating reports of connectivity issues in the North America region.
Posted May 24, 2023 - 06:34 PDT
This incident affected: Boostlingo Voice (Boostllingo Voice IVR, Boostlingo Network Traversal Service, Boostlingo Speech Recognition), Boostlingo Portal (Boostlingo Interpreter Portal, Boostlingo Requestor Portal), and Boostlingo Video (Boostlingo Group Rooms, Boostlingo Communication REST API).