7/28/21 - Voice and Video Service Disruptions
Incident Report for Boostlingo
Postmortem

At 11:27 am PST on July 28th, 2021 our monitoring systems had detected a slow down in connection times for the Boostlingo platform. The event was triggered by a threading bug in our management interface that caused the application services to become unstable and reset themselves.

This event was detected by the Boostlingo Development team who started working on the event by 11:29 am PST. We used a two-pronged approach to recover stability in services. First, the Development team had disabled the management interface causing the issue to occur at 11:29 am PST. At 11:30 am PST we had observed that connection times were restored with no additional hang ups having been recorded. Second, we deployed a fix later in the evening on July 28th that contained improvements to the code for the management interface in an attempt to prevent the issue from occurring again in the future.

The identified bug affected users of Boostlingo services in the United States and had extended to the web application as well as voice and video services. Users located outside of the United States who are on alternative servers were not affected by this bug.

Posted Aug 02, 2021 - 18:59 PDT

Resolved
The Boostlingo team had observed a brief interruption of services on July 28th, 2021 between 11:27 am PST and 11:30 am PST. During this time, OPI, VRI, and VRI calls may have been disrupted or had become unavailable. At 11:30 am PST, voice and video services had returned to normal and no additional issues have been recorded since this time.

We will write a postmortem for the incident once we have had a chance to discuss the root cause of the issue. Future updates can be found on our status page at: https://status.boostlingo.com/
Posted Jul 28, 2021 - 11:00 PDT