Mobile Application (iOS and Android) - Errors accessing appointments
Incident Report for Boostlingo
Resolved
Our team has concluded our monitoring and can confirm that things are working as expected. We will share a technical post-mortem on this thread in the next 48 hours.
Posted Dec 11, 2024 - 07:19 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 10, 2024 - 06:45 PST
Monitoring
The update to address the issue impacting access to appointments in the InterpretManager mobile application has been successfully deployed to our US and Canadian servers.

We are pleased to report that this issue has been resolved, and full functionality of the appointments feature has been restored. We will continue to monitor the US and Canadian servers for the next 24hrs to continue to validate our fix.

Thank you for your patience and understanding as we worked to implement this fix. If you experience any further issues, please reach out to our support team.
Posted Dec 09, 2024 - 21:40 PST
Update
Update: We are pleased to share that our team has developed and tested a resolution for the issue affecting access to appointments in the InterpretManager mobile application.

This evening at 2345 EST we will deploy an update to our US and Canadian servers to implement this fix. While we do not anticipate any downtime or interruptions during the deployment, our team will actively monitor the process to ensure a seamless experience.

We appreciate your patience and understanding as we work to restore full functionality to the appointments feature.
Posted Dec 09, 2024 - 20:31 PST
Identified
Our development team has identified the root cause of this issue and is working on a resolution. We will provide additional information about the root cause itself and the timeline for a resolution through our status page.
Posted Dec 09, 2024 - 11:33 PST
Investigating
Our team is investigating an issue accessing appointments through the InterpretManager mobile application. Users may experience an error message stating that "Resource or action access is denied" or "Something went wrong. Please try again later" when logging into the application and navigating to or refreshing the appointments tab.

Users will also not be able to join scheduled appointments through the mobile application at this time. They can access individual appointments through the expenses tab and are still able to accept or decline new appointments.

Users are able to navigate to other tabs of the application and access all other functionality. They may need to first dismiss the error message related to the appointments tab.

On-demand functionality is not impacted by this incident. Users ARE able to place and accept on-demand calls through the mobile application.

We will post additional updates to our status page.
Posted Dec 09, 2024 - 08:16 PST
This incident affected: InterpretManager Mobile Application (Appointments).