Connectivity issues in North America
Incident Report for Boostlingo
Postmortem

Issues with SignalR service that was dropping connections causing our server to hit critical hot code paths, which then caused thread contention and thread pool exhaustion.

 

Steps taken to resolve:

  1. When a call is completed we previously use synchronous api calls to update that call record to communicate that it was hung up.  These API calls in cases would wait for a response which created performance issues during high volume hours.  Moving these API calls to async operations allows them to run in parallel and keep the application stable.
  2. We optimized code paths to improve cpu utilization.
  3. We added capacity to our real-time communication service, MS Azure SignalR, essentially scaling up the service to handle a higher volume of real-time connections and messages.
  4. We made improvements to our database by adding or modifying four indexes which help speed up data retrieval for call specific tables.
  5. We updated maintenance task on our DB which are crucial activities performed to optimize the performance of a database by organizing and refreshing index structures and statistics.
  6. Deeper Monitoring, Tracing and Profiling tools implemented to help us identify root cause more efficiently, provide better visibility into our products and enable incident managers to respond before an issue has impact on important services.
Posted Jun 02, 2023 - 14:34 PDT

Resolved
We have concluded our monitoring and confirmed that the correct action has been taken. We will update this incident with a post-mortem in the next 24-48 hours.
Posted May 31, 2023 - 15:55 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 31, 2023 - 12:17 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 31, 2023 - 11:42 PDT
Investigating
We are investigating reports of connection issues and slow loading speeds across our US server.
Posted May 31, 2023 - 11:25 PDT
This incident affected: Boostlingo Messaging (Boostlingo SMS, Boostlingo EMail API v3), Boostlingo Voice (Boostllingo Voice IVR, Boostlingo Network Traversal Service, Boostlingo Speech Recognition), Boostlingo Portal (Boostlingo Interpreter Portal, Boostlingo Requestor Portal), and Boostlingo Video (Boostlingo Group Rooms, Boostlingo Communication REST API).