Reports of users unable to access web and mobile platform across US Server
Incident Report for Boostlingo
Postmortem

Starting at 7:46 am pst our team identified a spike in error messages related to platform stability. At that same time we received reports from users that they were unable to access the platform on web and mobile devices. Our team took immediate action to mitigate the impact of the issue by increasing capacity and stopping processes which were leading to the errors. Once we took that action we saw a quick reduction in errors and an increase in platform accessibility.

From 7:46 am pst to 7:54 am pst some users would have had issues accessing the platform with the greatest impact between 7:47 and 7:49 am pst. The majority of IVR calls should have connected as expected though there was a small increase in errors specifically related to IVR calls. In these instances ending the call and placing a new one would likely have been sufficient to connect as expected. We will continue to investigate the root causes for these issues and take steps to further increase platform stability.

Posted Jan 11, 2024 - 09:22 PST

Resolved
Our team has concluded our monitoring and found that the platform has remained stable and accessible since we took action.

We did have reports from two users that they needed to clear their browser cache and hard-refresh their browser to re-establish their connections after being unable to access the platform during the incident window. If you have any users who continue to experience issue please let us know asap and we can help with next steps: support@boostlingo.com.

We will provide an update on this page shortly with additional information around the scope of the incident and the action we took. Thank you.
Posted Jan 11, 2024 - 08:45 PST
Monitoring
We are investigating reports of slow loading pages and increased error messages across the US server starting today at 7:46 am pst. Our team took immediate action and generally IVR calls should not have been effected.

Access to the platform has been restored and our team will monitor to ensure stability.

We will follow up with additional information here as soon as we have it. Please subscribe to ensure you receive updates as soon as they are available.
Posted Jan 11, 2024 - 08:06 PST
This incident affected: Boostlingo Portal (Boostlingo Interpreter Portal, Boostlingo Requestor Portal).