Investigating potential issues placing on-demand calls on US server.

Incident Report for Boostlingo

Postmortem

A Database critical for call routing reached its maximum capacity, which resulted in preventing new call routing entries. While active calls were not impacted users were unable to initiate new calls during the incident window. The affected database components were reset, and routing functionality was restored. A long-term fix to increase database capacity was implemented with our next release after the incident. The development and product teams have also performed preventative maintenance cleanup jobs to reduce the chances for similar incidents in the future.

Posted Feb 07, 2025 - 14:27 PST

Resolved

Our team has concluded their monitoring and calls are able to be placed and will route as expected. We will follow up on this incident in the next three business days with a post mortem.
Posted Jan 09, 2025 - 10:54 PST

Monitoring

Our development team has identified the cause of the issues and implemented a fix on the backend. We are monitoring results. Calls should connect and route as expected at this time.
Posted Jan 09, 2025 - 10:42 PST

Investigating

Our monitoring systems have identified a potential issue related to On demand calls placed on our US server.

Our development team has been notified and are working on identifying the issue. We will follow up with additional information here as soon as we have it. Please subscribe to ensure you receive updates as soon as they are available.
Posted Jan 09, 2025 - 10:36 PST
This incident affected: Boostlingo Voice (Boostllingo Voice IVR, Boostlingo Network Traversal Service, Boostlingo Speech Recognition, SIP Proxy), Boostlingo Video (Boostlingo Group Rooms, Boostlingo Communication REST API), InterpretManager Mobile Application (On-Demand), and Twilio Voice, North America.