Connectivity issues in North America
Incident Report for Boostlingo
Postmortem

We experienced a series of database deadlocks that caused several services to lose access to the database and required a restart.
The occurrence of deadlock situations in database tables resulted in numerous queries timing out, ultimately leading to several services losing database access and requiring a restart.
The identified queries responsible for locking the tables were rectified, and additional indexes were incorporated to enhance performance concerning the updated queries.

Posted May 17, 2023 - 15:20 PDT

Resolved
This incident has been resolved.
Posted May 16, 2023 - 09:02 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2023 - 07:41 PDT
Investigating
We are investigating reports of connectivity issues in the North America region.
Posted May 16, 2023 - 07:11 PDT
This incident affected: Boostlingo Voice (Boostllingo Voice IVR, Boostlingo Network Traversal Service, Boostlingo Speech Recognition), Boostlingo Portal (Boostlingo Interpreter Portal, Boostlingo Requestor Portal), and Boostlingo Video (Boostlingo Group Rooms, Boostlingo Communication REST API).