Increase in Connection Times to Update Online/Offline Status and Download Reports/Logs
Incident Report for Boostlingo
Postmortem

At 12:35 am PST on September 28th, 2021 our monitoring systems had detected slowdowns in connection times for certain portions of the Boostlingo platform. For Requestors, this resulted in the Caller window occasionally having a hard time connecting to the server and would require a manual browser refresh. For Interpreters, the Online/Offline button would sometimes stop working and would require a manual browser refresh. For LSC Administrators, this would have affected the downloading of Reports/ Call Logs to CSV. The event was triggered by a third-party host service we use for 2-way communication and would affect connections at-random.

This event was detected by the Boostlingo Development team who started working on the event by 3 am PST on September 28th. We reached out to the third-party host service who had determined that a system patch had caused the issue. This was resolved on September 30th at 3:44 am PST when the host service migrated our instances to a new cluster in their servers.

The identified bug affected users of Boostlingo services in the United States and had extended to the Caller window, setting Online/Offline status, and downloading of Reports/Call Logs to CSV. Users located outside of the United States who are on alternative servers were not affected by this issue.

Posted Oct 01, 2021 - 15:50 PDT

Resolved
The Boostlingo team has now verified that services for the Boostlingo and InterpretManager web portals have returned to normal and no additional connectivity issues have been observed. We will write a postmortem for the issue and post it to our status page once our team has had an opportunity to further discuss the event.
Posted Sep 30, 2021 - 11:36 PDT
Investigating
Our monitoring systems have detected a potential decrease in availability for sections of Boostlingo's web services, such as updating Online/Offline status and the downloading of Reports and Call Logs. The Boostlingo team is currently investigating and will post updates to the status page as more information becomes available.

Boostlingo Status Page: https://status.boostlingo.com/
Posted Sep 29, 2021 - 09:55 PDT
This incident affected: Boostlingo Portal (Boostlingo Interpreter Portal, Boostlingo Requestor Portal).