Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 04, 2025 - 18:00 PDT
Scheduled
The Boostlingo team will re-deploy Version 7.9 to our US servers, completing Phase 2 of 2 for this release. This final deployment resolves an issue identified during the previous 7.9 release attempt on US servers.
Expected Impact: Services should remain available for most of the window; however, there may be short periods (several minutes or more) when some features are temporarily unavailable while components update and restart.
Further updates — including confirmation once the release is complete — will be posted to our status page.
Posted Sep 02, 2025 - 15:22 PDT
This scheduled maintenance affected: Boostlingo Messaging (Boostlingo SMS, Boostlingo EMail API v3), Boostlingo Voice (Boostllingo Voice IVR, Boostlingo Network Traversal Service, Boostlingo Speech Recognition, SIP Proxy), Boostlingo Portal (Boostlingo Interpreter Portal, Boostlingo Requestor Portal), InterpretManager Mobile Application (Appointments, On-Demand), Boostlingo Video (Boostlingo Group Rooms, Boostlingo Communication REST API), and Twilio Voice, North America, Twilio SMS Long Code, North America.