Reports of slow loading web pages and intermittent connection issues across all servers.

Incident Report for Boostlingo

Resolved

Our team has concluded our monitoring and validated the changes. This is resolved.
Posted May 27, 2026 - 18:45 PDT

Monitoring

Our team observed increased latency and API errors which impacted system performance and contributed to increased CPU usage. We took action to reduce latency and observed a reduction in CPU usage which stabilized the system. Our team will continue to monitor performance and will take additional action as necessary.
Posted May 27, 2026 - 17:23 PDT

Investigating

We are investigating reports of slow loading pages and intermittent connection issues across all servers.

We will follow up with additional information here as soon as we have it. Please subscribe to ensure you receive updates as soon as they are available.
Posted May 27, 2026 - 15:32 PDT
This incident affected: Boostlingo Portal (Boostlingo Interpreter Portal, Boostlingo Requestor Portal) and InterpretManager Mobile Application (On-Demand).